Truck & Bus Forum Truck & Bus Forum
21:12
Welcome to the Truck & Bus Forums
Welcome!A very warm welcome to truckandbusforum.com, a completely FREE online community for people worldwide with an interest in vintage and modern trucks and buses.

Click here to go to the forums home page and find out more.
Please feel free to join by clicking HERE.

Go Back   Truck & Bus Forum > Members Area > Say Hello

Reply
 
Thread Tools
  #1  
Old 3rd June 2020, 11:16
pazzyboy pazzyboy is offline  
user
 
Join Date: Jun 2020
Location: wales
Posts: 1
tk gauge problem

hello everyone, I am hoping that someone out there can help me with a problem I have with my lorry. I have bedford tk 1260 1983. Recently both the fuel gauge and temperature gauge are reading lower than they should. I think they must run off the same power source, but why are both so low. the temperature reads just above 50 when it should be just above 80. Any thoughts.
many thanks
Brendan
Reply With Quote
  #2  
Old 30th June 2020, 08:47
TimS TimS is offline  
Member
 
Join Date: May 2020
Location: Crewe
Posts: 3
Hi, we have a '66 TK that has suffered a similar problem, but neither gauge worked at all. We tracked that down to the incorrect wiring of the common power lead in the speedo cluster, but now the temp reads just above 'C' and the fuel reads full all the time. We've sourced a temperature sender that we're going to fit, but can't find a fuel sender unit, so might look at getting it repaired.
Your later model will have a very similar speedo cluster, but a printed circuit board instead of the simple wire-to-gauge setup that ours has. I'd have a look there first, making sure that all connections are good and clean and the circuit board is intact. There are a few speedo clusters on eBay, but they're a bit pricey.
Reply With Quote
Reply

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 21:12.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.